Debian problem

Don´t be shy, Linux is fun! =)
Post Reply
User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Debian problem

Post by isapiens »

Ok, well i got debian as b_brain recomended. However, i failed to install it. I wanted to do a dual boot installation: XP and Linux. I installed XP first, that left me with 17 Gigs of free space(my secod partition) Then i tryed to instull debian...Everything went fine, it created 2 separate partitions:priamary-ext3 and logical-swap. then it told me to install the programm that would let me chose which OS to boot, i did that. (also told me to choose a kernel, did that too)Then i clicked finish and boot button and then it didnt work. it said "Kernel Panic:Attemted to kill init!"
I tryed to reinstall but it says "no root fyle system is defined". The only way i can reinstall is format the created partitions and do the same thing again. I did that, but it didnt work.
Need help, i am tyred....

User avatar
sternbildchen
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 421
Joined: 26 Apr 2006, 16:00
15
Location: Germany

Post by sternbildchen »

Hm try to create a Boot Partition with about 1gb on ur Master Harddisk.
And define it as the boot partition.

I'm not sure if this solves your problem, but i think its worth a try. :)

(Another thing could be that you, like the error says, just forgot to define which disk is root.)

User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Post by isapiens »

well i am a total noob when it comes to linux, so how would i define the root? i dont even know what the hell is root? is it like the windows boot files?
Linux people gota make the installation a bit more self explanatory or smth...

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11600
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

well, it seems you missed to setup the / -partition... :wink:
you need to setup 3 partitions: / (or root), ext and swap.
if you don´t want to do it manually you can simply chose the empty space for the install and accept the partitions recommended by the setup wizard... :wink:

you can also find all info here:
http://www.nl.debian.org/releases/sarge/installmanual

User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Post by isapiens »

ok well attmept #32

When you click "Automatically partition the free space" it gives you 3 choices:

1. All files in one partition (recomended for new users)
2. Desktop machine
3. multi-user workstation

When i pick the first one it only creates 3 partitions, therefore i tryed the second one and it successfully created 3 partitions, one of them was named "/".
However, after rebooting it gave me the same error. I boot from the debian cd and it tells me i have 3 partitions:
1) primary (4.9 Gb) ext 3
2) logical 600 MB (swap 3)
3) logical 12.5 Gb (swap 3)

I didnt not do this manually, id did it automatically. any suggestions on maybe how i specify the root partition location to the system?

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11600
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

hmm...well, try the first option then, accept the settings and see what happens...I never had a problem like this with Debian, usually I chose the first option and it works fine even on a multi-Linux system (Red Hat and Debian).

User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Post by isapiens »

i figured i will just use this old thread i started. I have been having this dual-boot problem for a long time.

Basically what happens, is that when one of my OS's crashed the reinstallation of it fucks up everything. There is bunch of stuff on internet about partitions, Grub instartactions and etc... I really didnt understand half of them and just blindly following them made everything worse.

Here is just what i know i gota do to make my stuff work.

1. Cylinder-head-sector error is what screws everything up. It has a limit of 8Gb or smth like that. so when you install your OS and its boot information is not located within that are then GRUB can not load it.

2. Do not overwrite MBR with GRUB. Install it on the linux partition which might be dev/sda2

Right now i have a retarded setup. First GAG recognizes two partitions: XP and linux. After you click linux, grub pops up and then you can select Linux.

Basically i gota get rid of the first boot manager and make my second partition primary (i think thats the sollution) This booting stuff is not as easy as it seams if you are not lucky, and windows made sure that you are not.

cheers
Fluoridation is the most monstrously conceived and dangerous communist plot we have ever had to face.

Penumbral
On the way to fame!
On the way to fame!
Posts: 40
Joined: 06 Jul 2007, 16:00
14
Contact:

Post by Penumbral »

isapiens wrote: However, after rebooting it gave me the same error. I boot from the debian cd and it tells me i have 3 partitions:
1) primary (4.9 Gb) ext 3
2) logical 600 MB (swap 3)
3) logical 12.5 Gb (swap 3)
Im not 100% sure i understand you, but Ill try to cover all the things that you should do when getting a dual boot working. This is just a super basic guidline, read this and hit me back with whatever questions it raises for you. Hope I can help.

First off none of those are windows drives? Windows uses ntfs or vfat/fat32. In this case it may be best to not create a new partition for windows, just leave the space empty, and use the windows install disk to create the partition. go with fat.

You should be able to have up to four primary partitions. While its not required to use primary partitions I would because of the error you are getting. Do the partitioning manually with cfdisk make (at least) 3. 1 for XP 1 for Debian 1 for swap.

cfdisk is under the advanced options in the partition setup (I think) or its some other gui program both work the same if I remember right. delete your old partitions and create new once, after this you will need to format them. That should happen when you get to the install stage.

Now reinstall windows.

Now if this is the etch net install you really need to configure your network before installing the OS.

Is there a specific reason you are not installing GRUB to the MBR? beacuse that should make it only go to one boot screen.

The first time booting you will not be able to go into windows. You will need to boot debian and go to the grub.conf file in your boot directory. Just add your windows root drive and that should allow you to boot into either right from the start.

Because this is debian it would also be a good to add your XP drive to your fstab file in /etc/

If for some reason sudo is not working to change the grub.conf file (happened to me once) there are two options

Code: Select all

su
password
cd ..
nano /boot/(directory where grub is)/grub.conf
Then you can edit it in your terminal program. Or you can change your login screen to allow you to login as root.

As far as actually configuring the files there are tons of examples out there, but if you need it I can post mine.
Non Serviam

User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Post by isapiens »

well you solution involves reinstalling both windows and linux, correct?

But what if i already have XP and just want to reinstall linux? When i do that, grub overwrites MBR and after a reboot encounters error 17 or 18. And i found out that it is caused by a "cylinder head" being out of range for the linux partition. So the only way I can make it work is install GRUB on the Linux partition.

basically it doesnt work for me when i overwrite MBR.

But your way is right. Thats how i did it when i was installing everything from the beginning and i just never got that "bios cylinder head" error, so it all worked out. I didnt even have to edit any grub cofig files, it just detected everything.
Fluoridation is the most monstrously conceived and dangerous communist plot we have ever had to face.

Penumbral
On the way to fame!
On the way to fame!
Posts: 40
Joined: 06 Jul 2007, 16:00
14
Contact:

Post by Penumbral »

what I dont get is your partition table:
1) primary (4.9 Gb) ext 3
2) logical 600 MB (swap 3)
3) logical 12.5 Gb (swap 3)
12.5Gb Swap is just not understandable. I am guessing that is you XP partition, either that or the 4.9. But niether of those are Windows fileing systems? This could give you a read error on the drive.

If that is not so have you just tried using LILO instead of GRUB? Its not hard to change, and in my experience it works just as well or better.
Non Serviam

User avatar
isapiens
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 533
Joined: 05 May 2006, 16:00
15
Location: Turn around

Post by isapiens »

hehe i finally found this post i made like a year ago. Since then i got a little bit better in linux so i have solved my problems with dual booting.

Here is what my problem was. I would dual boot windows and linux, then i would delete linux and try to reinstall and it wouldnt work. This happens because the bios can not access the boot sector. Apperently for the old bios systems(the one i have) the boot sector has to be within first 1024b of the hard disk.

Therefore here is what you do:
1) You take a partition manager and move(resize) you windows partition a little bit to the "left" so you have some free space at the beginning of the hard disk.
2)then you start installing linux and create partitions manually: a) /boot b) /swap c) and finally the root partition /

I made boot and swap 100mb each but i am sure they can be smaller. The / partition is bigger obvioulsy.(10Gb)

Anyway, then it asks to moun those partition, therefore YOU GOTA MAKE sure that you mound the /boot sector on the partition that we created at the beginning of the hard drive.

Does this make sense?
Fluoridation is the most monstrously conceived and dangerous communist plot we have ever had to face.

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11600
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

yeup...the /boot partition is the place where the kernel is temporary loaded to during startup, so 100mb is enough (usually already 50mb is enough, but the newer kernels get bigger and bigger, so it's better to give it some extra space).
BUT the /boot partition needs to be formated as ext3, not as swap... :wink:

Post Reply