startx problems

Don´t be shy, Linux is fun! =)
Post Reply
d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

startx problems

Post by d10b »

I cant get startx to run with topologilinux (based on slackware) running under colinux in windows. :) Basically trouble w/startx and slackware.

Googling "xf86EnableIOPorts: Failed to set IOPL for I/O" is no help at all.

The font dirs do exist but this logfile shows problems. Googling "Open APM failed (/dev/apm_bios) (No such device)" says this is a harmless msg not related to anything. It has to do with power management.

Any ideas?

xorg.0.log file shows:

Code: Select all

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.4.31 i686 [ELF] 
Current Operating System: Linux localhost 2.6.10-co-0.6.2 #5 Sat Feb 5 10:19:16 IST 2005 i686
Build Date: 25 September 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 11 20:47:51 2006
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "westinghouse"
(**) |   |-->Device "NVIDIA GeForce"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/local/".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local/").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/Speedo/".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/Speedo/").
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/TTF/,/
usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/
usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,/
usr/X11R6/lib/X11/fonts/cyrillic/"

(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such device)
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.7
        X.Org XInput driver : 0.4
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
        compiled for 6.8.2, module version = 1.0.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 6.8.2, module version = 1.0.0
        ABI class: X.Org Video Driver, version
(--) using VT number 7


Fatal server error:
xf86EnableIOPorts: Failed to set IOPL for I/O
It's easier to read code when it's not small and in the "

Code: Select all

" tags. -Stavros[/i]
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11610
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

hm, I looked around a little, seems it's a permissions problem and X can only be runned as root, try to make X runnable with user-rights:

Code: Select all

chmod 4711 /usr/bin/X11/Xorg
:wink:
Last edited by bad_brain on 12 Aug 2006, 10:39, edited 1 time in total.

d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

I ran it as run.

Post by d10b »

I was running it as root :)

"" (==) Using config file: "/etc/X11/xorg.conf" ""shows it's running doesn't it?
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

iopl

Post by d10b »

i just googled "IOPL" and it does have to do with permissions. thanks bb i cant wait until lunch so i can try this!

do you know while file contains the line to enable/disable CAP_SYS_RAWIO?
Last edited by d10b on 12 Aug 2006, 11:02, edited 1 time in total.
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11610
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

np, good luck! :)
running X on Slackware (or Slackware derivates) can be a pain in the ass, I had problems too when I tried Slackware 10.1 a while ago....

d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

Thanks

Post by d10b »

The thing is I've run Slackware before w/no problems. This is a distro based on slackware (Topologilinux). I thought slack was the easiest out of all of 'em.

I can't wait until it is all tuned up. It's going to be awesome running windows XP w/linux in a window.
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11610
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

well, imo the "easiest" are the mainstream distros like SuSe and Fedora/RedHat, Slackware and Debian for example are for a little more advanced users and the "hardcore" stuff are the BSD-ones like FreeBSD or OpenBSD....I only talk about the installation procedure, the easy ones are with Windows-like graphical installer i-face, the advanced ones are mostly with text-mode installer i-face and maybe need some manual configuration, and for the hardcore ones manual config is inevitable.
I've tried a couple of distros already, so I just can speak out of my own experience, for other people it could be different because of the hardware compatibility of each distro...:wink:

d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

Didn't work.

Post by d10b »

Code: Select all

chmod 4711 /usr/bin/X11/Xorg
This didn't work but I think your suggestion has put me on the right track as to where to look for an answer. Do you know anything about CAP_SYS_RAWIO? As to maybe while config file it's in to enable it. I think I have to put a line in with that enabled... like:

Code: Select all

+CAP_SYS_RAWIO
For some type of permission to ports for i/o.
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11610
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

ok, I looked around a little...
usually it´s enabled by default....is lids installed on the system?
if yes you can enable the CAP_SYS_RAWIO capability for X by:

Code: Select all

lidsadm -A -s /path/to/your/X_server -t -o CAP_SYS_RAWIO -j NO_INHERIT
I found no other comfortable way to enable CAP_SYS_RAWIO without compiling the kernel again, check this file:

Code: Select all

/usr/include/linux/capability.h

imo it would be easier to install lids and then enable it than compiling a new kernel: http://www.lids.org/
:wink:

d10b
Fame ! Where are the chicks?!
Fame ! Where are the chicks?!
Posts: 159
Joined: 05 Nov 2005, 17:00
16
Location: Saint Paul, MN
Contact:

Thanks again BB!

Post by d10b »

Thanks again for the help BB! Did I ever mention I really enjoy your site and I'm on it all day while at work :) I can't wait to try this...
``The true voyage of discovery lies not in seeking new landscapes, but in having new eyes``

User avatar
bad_brain
Site Owner
Site Owner
Posts: 11610
Joined: 06 Apr 2005, 16:00
16
Location: The zone.
Contact:

Post by bad_brain »

thank you very much, I'm proud to hear that! :D

Post Reply